]> Pileus Git - aweather/blobdiff - src/Makefile.am
Remove gnulib, it's a huge pain
[aweather] / src / Makefile.am
index b0852f26d93d24f56846bad49572c9fd0dc3db3d..fb2e6f5e4cc42e34a9a4a5f9e21fd8635fbadd8c 100644 (file)
@@ -26,7 +26,6 @@ wsr88ddec_LDFLAGS     = -mwindows
 aweather_SOURCES     += resource.rc
 aweather_LDFLAGS      = -mwindows
 aweather_CPPFLAGS    += -I$(top_srcdir)/lib
-aweather_LDADD       += $(top_srcdir)/lib/libgnu.la
 
 bin_PROGRAMS         += aweather-dbg
 aweather_dbg_SOURCES  = $(aweather_SOURCES)
@@ -51,3 +50,15 @@ gdb: all
 
 ddd: all
        ddd .libs/aweather
+
+memcheck: all
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --track-origins=yes            \
+                --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                --suppressions=/usr/lib/valgrind/default.supp \
+                .libs/aweather                 \
+       2> valgrind.out