]> Pileus Git - aweather/blobdiff - src/Makefile.am
Add new application icons
[aweather] / src / Makefile.am
index 47856d062c6ed60305ceabbcb4568227f2fa00cb..d3861ebfe9c8a9bb72ae79476ac5d4101dda6791 100644 (file)
@@ -1,26 +1,50 @@
 SUBDIRS = plugins
 
-AM_CFLAGS = -Wall --std=gnu99 
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic \
+              -Wl,--as-needed -Wl,--no-undefined
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
 aweather_CPPFLAGS = \
-       -DPKGDATADIR="\"$(pkgdatadir)\"" \
-       -DPLUGINSDIR="\"$(pkglibdir)\""
-aweather_CFLAGS   = $(GIS_CFLAGS) $(AM_CFLAGS)
-aweather_LDADD    = $(GIS_LIBS)
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DICONDIR="\"$(dots)$(datadir)/icons\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GRITS_LIBS)
 
 wsr88ddec         = wsr88ddec.c
-wsr88ddec_CFLAGS  = $(GLIB_CFLAGS) $(AM_CFLAGS)
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
+if WIN32
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+aweather_CPPFLAGS    += -I$(top_srcdir)/lib
+aweather_LDADD       += $(top_srcdir)/lib/libgnu.la
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
+
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       .libs/aweather -o -d 7
+       .libs/aweather -o -d 7 -s KOUN -t '2011-02-01 10:01Z'
+#.libs/aweather -o -d 7 -s KLSX -t '2010-12-31 17:56Z'
+#.libs/aweather -o -d 7 -s KDGX -t '2010-12-31 23:10Z'
+#.libs/aweather -o -d 7 -s KDGX -t '1999-05-03 23:51Z'
 
 gdb: all
        gdb .libs/aweather