]> Pileus Git - aweather/blobdiff - src/Makefile.am
(no commit message)
[aweather] / src / Makefile.am
index cca3efd5515bd094c6034880c356b4c4bc49a2af..c969493d750816406a4201c5a6d5800f1c29b0a6 100644 (file)
@@ -1,5 +1,11 @@
+AM_CPPFLAGS  = $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS)
+AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
+
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = aweather.c aweather.h cube.c cube.h
-aweather_CPPFLAGS = @PACKAGE_CFLAGS@
-aweather_LDADD    = @PACKAGE_LIBS@
+aweather_SOURCES  = aweather.c opengl.c radar.c ridge.c example.c 
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+test: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       ./aweather