]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index f8c79e8a9b0ad3d64d41927b9550fb308c98d430..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -1,15 +1,15 @@
-SUBDIRS = gis plugins
+SUBDIRS = plugins
 
 AM_CFLAGS   = -Wall --std=gnu99 
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+AM_CPPFLAGS = $(GIS_CFLAGS)
+LIBS        = $(GIS_LIBS)
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
-aweather_LDADD    = $(AM_LDADD) gis/libgis.la
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
 
 wsr88ddec       = wsr88ddec.c
 wsr88ddec_LDADD = -lbz2
@@ -18,10 +18,10 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7
 
 gdb: all
-       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
+       gdb .libs/aweather
 
 ddd: all
-       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
+       ddd .libs/aweather