]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index 96c7a6c3249a0eab2ce2a1852cf8669641d4e05e..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -1,15 +1,15 @@
-SUBDIRS = gis plugins
+SUBDIRS = plugins
 
 AM_CFLAGS   = -Wall --std=gnu99 
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+AM_CPPFLAGS = $(GIS_CFLAGS)
+LIBS        = $(GIS_LIBS)
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
-aweather_LDADD    = $(AM_LDADD) gis/libgis.la
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
 
 wsr88ddec       = wsr88ddec.c
 wsr88ddec_LDADD = -lbz2
@@ -18,21 +18,10 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7
 
 gdb: all
-       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
+       gdb .libs/aweather
 
 ddd: all
-       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
-
-memcheck: all
-       LD_LIBRARY_PATH=gis/.libs               \
-       G_SLICE=always-malloc                   \
-       G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
-                --leak-resolution=high         \
-                --num-callers=100              \
-                --suppressions=gtk.suppression \
-                .libs/aweather                 \
-       2> valgrind.out
+       ddd .libs/aweather