]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index 89408488b632009e423162656474b8fa1dec62b6..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -1,18 +1,27 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather
+SUBDIRS = plugins
 
-aweather_SOURCES  = \
-       aweather.c       aweather.h       \
-       location.c       location.h       \
-       opengl.c         opengl.h         \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GIS_CFLAGS)
+LIBS        = $(GIS_LIBS)
 
+bin_PROGRAMS = aweather wsr88ddec
+aweather_SOURCES  = main.c \
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
+
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       ./aweather
+       .libs/aweather -o -d 7
+
+gdb: all
+       gdb .libs/aweather
+
+ddd: all
+       ddd .libs/aweather