]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index 3552e3053487e8e5d274dbea078defd5db3874b9..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -8,7 +8,8 @@ bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
 
 wsr88ddec       = wsr88ddec.c
 wsr88ddec_LDADD = -lbz2
@@ -17,10 +18,10 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7
 
 gdb: all
-       gdb aweather
+       gdb .libs/aweather
 
 ddd: all
-       ddd aweather
+       ddd .libs/aweather