]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index 18b7fba1dc450c034846f94261f4dc103e13c73a..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -1,38 +1,27 @@
-AM_LDFLAGS   = $(RSL_LIBS) $(GTK_LIBS)
-AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-bin_PROGRAMS = aweather wsr88ddec
+SUBDIRS = plugins
+
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GIS_CFLAGS)
+LIBS        = $(GIS_LIBS)
 
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-radar-colormap.c           \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
 
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
 
-# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       ./aweather
+       .libs/aweather -o -d 7
 
 gdb: all
-       gdb ./aweather
+       gdb .libs/aweather
 
 ddd: all
-       ddd ./aweather
-
-memcheck:
-       G_SLICE=always-malloc                   \
-       G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
-                --leak-resolution=high         \
-                --num-callers=50               \
-                --suppressions=gtk.suppression \
-                ./aweather                     \
-       2> memcheck.log
+       ddd .libs/aweather