]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix misc bugs and bump version to 0.3
[aweather] / src / Makefile.am
index 18976bc36dac8d84f8eb08932cbe2116f5459888..c955106bbb16b09f19d10b6ac3e9c3e49c5e6187 100644 (file)
@@ -1,35 +1,27 @@
-SUBDIRS = gis plugins
+SUBDIRS = plugins
 
-AM_CFLAGS = -Wall -Werror -Wno-unused --std=gnu99 
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GIS_CFLAGS)
+LIBS        = $(GIS_LIBS)
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = -DDATADIR="\"$(datadir)\"" $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
-aweather_LDADD    = gis/libgis.la $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
+aweather_CPPFLAGS = $(AM_CPPFLAGS) \
+                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
 
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDFLAGS = -lbz2
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       ./aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7
 
 gdb: all
-       gdb ./aweather
+       gdb .libs/aweather
 
 ddd: all
-       ddd ./aweather
-
-memcheck:
-       G_SLICE=always-malloc                   \
-       G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
-                --leak-resolution=high         \
-                --num-callers=100              \
-                --suppressions=gtk.suppression \
-                ./aweather                     \
-       2> valgrind.out
+       ddd .libs/aweather