]> Pileus Git - aweather/blobdiff - src/Makefile.am
Update compat includes
[aweather] / src / Makefile.am
index fb3d4f6a69df51d6a1c4f3c504dc572f99dfef08..c37ed21a50f974a63e36dcb679fedd0d47323851 100644 (file)
@@ -7,6 +7,8 @@ if !SYS_MAC
 AM_LDFLAGS += -Wl,--as-needed 
 endif
 
+EXTRA_DIST  = compat.h
+
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
@@ -34,6 +36,11 @@ aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
 aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
+if SYS_MAC
+aweather_CPPFLAGS    += $(MAC_CFLAGS)
+aweather_LDADD       += $(MAC_LIBS)
+endif
+
 .rc.o: ../data/icons/48x48/aweather.ico
        $(RC) -o $@ $<
 
@@ -41,7 +48,8 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       .libs/aweather -o -d 7 -s KOUN -t '2011-02-01 10:01Z'
+       .libs/aweather -o -d 5
+#.libs/aweather -o -d 7 -s KOUN -t '2011-02-01 10:01Z'
 #.libs/aweather -o -d 7 -s KLSX -t '2010-12-31 17:56Z'
 #.libs/aweather -o -d 7 -s KDGX -t '2010-12-31 23:10Z'
 #.libs/aweather -o -d 7 -s KDGX -t '1999-05-03 23:51Z'