]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix memory leaks
[aweather] / src / Makefile.am
index d3861ebfe9c8a9bb72ae79476ac5d4101dda6791..b72794b611c36888c3401567e652f5414e5592ae 100644 (file)
@@ -34,7 +34,7 @@ aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
 aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
-.rc.o: ../data/aweather.ico
+.rc.o: ../data/icons/48x48/aweather.ico
        $(RC) -o $@ $<
 
 CLEANFILES = gmon.out valgrind.out
@@ -51,3 +51,15 @@ gdb: all
 
 ddd: all
        ddd .libs/aweather
+
+memcheck: all
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --track-origins=yes            \
+                --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                --suppressions=/usr/lib/valgrind/default.supp \
+                .libs/aweather                 \
+       2> valgrind.out