]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix memory leaks
[aweather] / src / Makefile.am
index 84399d487b3b77ed18c58501a6591e5a6bbfcfee..b72794b611c36888c3401567e652f5414e5592ae 100644 (file)
@@ -1,27 +1,65 @@
 SUBDIRS = plugins
 
-AM_CFLAGS   = -Wall --std=gnu99 
-AM_CPPFLAGS = $(GIS_CFLAGS)
-LIBS        = $(GIS_LIBS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic \
+              -Wl,--as-needed -Wl,--no-undefined
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) \
-                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
+aweather_CPPFLAGS = \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DICONDIR="\"$(dots)$(datadir)/icons\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GRITS_LIBS)
 
-wsr88ddec       = wsr88ddec.c
-wsr88ddec_LDADD = -lbz2
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+aweather_CPPFLAGS    += -I$(top_srcdir)/lib
+aweather_LDADD       += $(top_srcdir)/lib/libgnu.la
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
+endif
+
+.rc.o: ../data/icons/48x48/aweather.ico
+       $(RC) -o $@ $<
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       .libs/aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7 -s KOUN -t '2011-02-01 10:01Z'
+#.libs/aweather -o -d 7 -s KLSX -t '2010-12-31 17:56Z'
+#.libs/aweather -o -d 7 -s KDGX -t '2010-12-31 23:10Z'
+#.libs/aweather -o -d 7 -s KDGX -t '1999-05-03 23:51Z'
 
 gdb: all
        gdb .libs/aweather
 
 ddd: all
        ddd .libs/aweather
+
+memcheck: all
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --track-origins=yes            \
+                --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                --suppressions=/usr/lib/valgrind/default.supp \
+                .libs/aweather                 \
+       2> valgrind.out