]> Pileus Git - aweather/blobdiff - src/Makefile.am
libgis -> grits: Update everything
[aweather] / src / Makefile.am
index 535b1d052f7b3c887197800a2154cb93dbd32014..9c05599e13ff77923af0019896f9c4e9ac155ae2 100644 (file)
@@ -1,6 +1,6 @@
 SUBDIRS = plugins
 
-AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_LDFLAGS  = -Wl,--export-dynamic
 
 bin_PROGRAMS = aweather wsr88ddec
@@ -8,17 +8,26 @@ aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
 aweather_CPPFLAGS = \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
        -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
        -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
-aweather_LDADD    = $(GIS_LIBS)
+aweather_LDADD    = $(GRITS_LIBS)
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
 if WIN32
-AM_LDFLAGS       += -mwindows 
-aweather_SOURCES += resource.rc
-dots              = ..
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
 .rc.o: ../data/aweather.ico