]> Pileus Git - aweather/blobdiff - src/Makefile.am
Add some files dist tarballs
[aweather] / src / Makefile.am
index 67a788a46f698b5fadf6f94e058f68a358aa7778..7bba88f8b6bc0714e886754d2ece864f2c9e2e8a 100644 (file)
@@ -1,7 +1,38 @@
-bin_PROGRAMS = aweather
+SUBDIRS = plugins
 
-aweather_SOURCES  = aweather.c opengl.c cube.c radar.c 
-aweather_CPPFLAGS = @PACKAGE_CFLAGS@ -I/usr/local/trmm/GVBOX/include/
-aweather_LDADD    = @PACKAGE_LIBS@ -L/usr/local/trmm/GVBOX/lib/ -lrsl
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
 
+bin_PROGRAMS = aweather wsr88ddec
+aweather_SOURCES  = main.c \
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GIS_LIBS)
 
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+AM_LDFLAGS       += -mwindows 
+aweather_SOURCES += resource.rc
+dots              = ..
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
+test: all
+       .libs/aweather -o -d 7
+
+gdb: all
+       gdb .libs/aweather
+
+ddd: all
+       ddd .libs/aweather