]> Pileus Git - aweather/blobdiff - src/Makefile.am
Add -no-undefined for win32 build
[aweather] / src / Makefile.am
index 9b8803785585c36284ce8c85f3be4e7d05f398f0..7203aa093473542658c0580caed79f3aed9f5444 100644 (file)
@@ -1,7 +1,8 @@
 SUBDIRS = plugins
 
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
-AM_LDFLAGS  = -Wl,--export-dynamic
+AM_LDFLAGS  = -Wl,--export-dynamic \
+              -Wl,--as-needed -Wl,--no-undefined
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
@@ -23,6 +24,8 @@ wsr88ddec_LDFLAGS     = -mwindows
 
 aweather_SOURCES     += resource.rc
 aweather_LDFLAGS      = -mwindows
+aweather_CPPFLAGS    += -I$(top_srcdir)/lib
+aweather_LDADD       += $(top_srcdir)/lib/libgnu.la
 
 bin_PROGRAMS         += aweather-dbg
 aweather_dbg_SOURCES  = $(aweather_SOURCES)