]> Pileus Git - aweather/blobdiff - src/Makefile.am
Add better debugging support on Windows
[aweather] / src / Makefile.am
index b0ea82cbb609e94b6b606ad89b6ae9d450eeabaa..6a56bc4830308cc9a01698fe9a7f3f2fe68594be 100644 (file)
@@ -1,19 +1,38 @@
 SUBDIRS = plugins
 
-AM_CFLAGS = -Wall --std=gnu99 
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
-aweather_CFLAGS   = $(GIS_CFLAGS) $(AM_CFLAGS)
+aweather_CPPFLAGS = \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
 aweather_LDADD    = $(GIS_LIBS)
 
 wsr88ddec         = wsr88ddec.c
-wsr88ddec_CFLAGS  = $(GLIB_CFLAGS) $(AM_CFLAGS)
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
+if WIN32
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
+
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in