]> Pileus Git - aweather/blobdiff - src/Makefile.am
Use/update reflectivity colormap
[aweather] / src / Makefile.am
index 64939a31a32ffdedc815002f3948c54025c90b0c..6a56bc4830308cc9a01698fe9a7f3f2fe68594be 100644 (file)
@@ -8,7 +8,6 @@ aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
 aweather_CPPFLAGS = \
-       -DBROWSER="\"$(browser)\"" \
        -DHTMLDIR="\"$(dots)$(htmldir)\"" \
        -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
        -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
@@ -18,12 +17,17 @@ wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
 if WIN32
-AM_LDFLAGS       += -mwindows 
-aweather_SOURCES += resource.rc
-dots              = ..
-browser           = "open"
-else
-browser           = "xdg-open"
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
 .rc.o: ../data/aweather.ico