]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix default browser
[aweather] / src / Makefile.am
index c969493d750816406a4201c5a6d5800f1c29b0a6..64939a31a32ffdedc815002f3948c54025c90b0c 100644 (file)
@@ -1,11 +1,42 @@
-AM_CPPFLAGS  = $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS)
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
+SUBDIRS = plugins
 
-bin_PROGRAMS = aweather
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
 
-aweather_SOURCES  = aweather.c opengl.c radar.c ridge.c example.c 
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+bin_PROGRAMS = aweather wsr88ddec
+aweather_SOURCES  = main.c \
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = \
+       -DBROWSER="\"$(browser)\"" \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GIS_LIBS)
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+AM_LDFLAGS       += -mwindows 
+aweather_SOURCES += resource.rc
+dots              = ..
+browser           = "open"
+else
+browser           = "xdg-open"
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       ./aweather
+       .libs/aweather -o -d 7
+
+gdb: all
+       gdb .libs/aweather
+
+ddd: all
+       ddd .libs/aweather