]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix default browser
[aweather] / src / Makefile.am
index 535b1d052f7b3c887197800a2154cb93dbd32014..64939a31a32ffdedc815002f3948c54025c90b0c 100644 (file)
@@ -8,6 +8,8 @@ aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
 aweather_CPPFLAGS = \
+       -DBROWSER="\"$(browser)\"" \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
        -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
        -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
 aweather_LDADD    = $(GIS_LIBS)
@@ -19,6 +21,9 @@ if WIN32
 AM_LDFLAGS       += -mwindows 
 aweather_SOURCES += resource.rc
 dots              = ..
+browser           = "open"
+else
+browser           = "xdg-open"
 endif
 
 .rc.o: ../data/aweather.ico