]> Pileus Git - aweather/blobdiff - src/Makefile.am
Fix default browser
[aweather] / src / Makefile.am
index 3552e3053487e8e5d274dbea078defd5db3874b9..64939a31a32ffdedc815002f3948c54025c90b0c 100644 (file)
@@ -1,26 +1,42 @@
 SUBDIRS = plugins
 
-AM_CFLAGS   = -Wall --std=gnu99 
-AM_CPPFLAGS = $(GIS_CFLAGS)
-LIBS        = $(GIS_LIBS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_CPPFLAGS = \
+       -DBROWSER="\"$(browser)\"" \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GIS_LIBS)
 
-wsr88ddec       = wsr88ddec.c
-wsr88ddec_LDADD = -lbz2
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+AM_LDFLAGS       += -mwindows 
+aweather_SOURCES += resource.rc
+dots              = ..
+browser           = "open"
+else
+browser           = "xdg-open"
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7
 
 gdb: all
-       gdb aweather
+       gdb .libs/aweather
 
 ddd: all
-       ddd aweather
+       ddd .libs/aweather