]> Pileus Git - aweather/blobdiff - src/Makefile.am
Adding some (commented out) support for generating iso surfaces.
[aweather] / src / Makefile.am
index 10c83f051789f8f84f4f32a12b604ed1b45ad131..620cdcb18f280288915bb1a3f8238f3c0343030d 100644 (file)
@@ -1,4 +1,3 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
 AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
 bin_PROGRAMS  = aweather wsr88ddec
 
@@ -11,11 +10,14 @@ aweather_SOURCES  = main.c \
        aweather-plugin.c aweather-plugin.h \
        data.c            data.h            \
        location.c        location.h        \
+       marching.c        marching.h        \
        plugin-radar.c    plugin-radar.h    \
        plugin-radar-colormap.c             \
        plugin-ridge.c    plugin-ridge.h    \
        plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+aweather_CPPFLAGS = -DDATADIR="\"$(datadir)\"" \
+       $(RSL_CFLAGS) $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
+aweather_LDADD    = $(RSL_LIBS) $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
@@ -29,7 +31,7 @@ MAINTAINERCLEANFILES = Makefile.in
        glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather -d 7
+       ./aweather -o -d 7 -s KVNX
 
 gdb: all
        gdb ./aweather