]> Pileus Git - aweather/blobdiff - src/Makefile.am
Win32 fixes and improvements
[aweather] / src / Makefile.am
index 4454da87393d3d43c300cd54149cf1459ac0dc10..535b1d052f7b3c887197800a2154cb93dbd32014 100644 (file)
@@ -1,23 +1,37 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather
+SUBDIRS = plugins
 
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
+
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       location.c       location.h       \
-       opengl.c         opengl.h         \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GIS_LIBS)
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+AM_LDFLAGS       += -mwindows 
+aweather_SOURCES += resource.rc
+dots              = ..
+endif
 
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       ./aweather
+       .libs/aweather -o -d 7
+
+gdb: all
+       gdb .libs/aweather
 
-debug: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       gdb ./aweather
+ddd: all
+       ddd .libs/aweather