]> Pileus Git - aweather/blobdiff - src/Makefile.am
Move RSL file handling to level2 object
[aweather] / src / Makefile.am
index c6b60557c5fcadae6a2f8e139d0dfd4c05c8e858..47856d062c6ed60305ceabbcb4568227f2fa00cb 100644 (file)
@@ -1,7 +1,29 @@
-AM_CPPFLAGS  = $(GTK_CFLAGS)
-AM_CFLAGS    = -Wall -Werror --std=gnu99
+SUBDIRS = plugins
 
-bin_PROGRAMS = aweather
+AM_CFLAGS = -Wall --std=gnu99 
 
-aweather_SOURCES  = aweather.c opengl.c cube.c radar.c 
-aweather_LDADD    = $(GTK_LIBS) -lrsl
+bin_PROGRAMS = aweather wsr88ddec
+aweather_SOURCES  = main.c \
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = \
+       -DPKGDATADIR="\"$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(pkglibdir)\""
+aweather_CFLAGS   = $(GIS_CFLAGS) $(AM_CFLAGS)
+aweather_LDADD    = $(GIS_LIBS)
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_CFLAGS  = $(GLIB_CFLAGS) $(AM_CFLAGS)
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
+test: all
+       .libs/aweather -o -d 7
+
+gdb: all
+       gdb .libs/aweather
+
+ddd: all
+       ddd .libs/aweather