]> Pileus Git - aweather/blobdiff - src/Makefile.am
Rename aweather-colormap.[ch] to radar-info.[ch]
[aweather] / src / Makefile.am
index 84399d487b3b77ed18c58501a6591e5a6bbfcfee..46630769a8b4d7def9a7f167e7230b77cac66ac8 100644 (file)
@@ -1,24 +1,45 @@
 SUBDIRS = plugins
 
-AM_CFLAGS   = -Wall --std=gnu99 
-AM_CPPFLAGS = $(GIS_CFLAGS)
-LIBS        = $(GIS_LIBS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
+AM_LDFLAGS  = -Wl,--export-dynamic
 
 bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
-aweather_CPPFLAGS = $(AM_CPPFLAGS) \
-                   -DPKGDATADIR="\"$(pkgdatadir)\"" -DPLUGINSDIR="\"$(pkglibdir)\""
+aweather_CPPFLAGS = \
+       -DHTMLDIR="\"$(dots)$(htmldir)\"" \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
+aweather_LDADD    = $(GRITS_LIBS)
 
-wsr88ddec       = wsr88ddec.c
-wsr88ddec_LDADD = -lbz2
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
+
+if WIN32
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
+endif
+
+.rc.o: ../data/aweather.ico
+       $(RC) -o $@ $<
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       .libs/aweather -o -d 7 -s KVNX
+       .libs/aweather -o -d 7 -s KLSX -t '2010-12-31 17:56Z'
+#.libs/aweather -o -d 7 -s KDGX -t '2010-12-31 23:10Z'
+#.libs/aweather -o -d 7 -s KDGX -t '1999-05-03 23:51Z'
 
 gdb: all
        gdb .libs/aweather