]> Pileus Git - aweather/blobdiff - src/Makefile.am
Rename aweather-colormap.[ch] to radar-info.[ch]
[aweather] / src / Makefile.am
index 64939a31a32ffdedc815002f3948c54025c90b0c..46630769a8b4d7def9a7f167e7230b77cac66ac8 100644 (file)
@@ -1,6 +1,6 @@
 SUBDIRS = plugins
 
-AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_LDFLAGS  = -Wl,--export-dynamic
 
 bin_PROGRAMS = aweather wsr88ddec
@@ -8,22 +8,26 @@ aweather_SOURCES  = main.c \
        aweather-gui.c      aweather-gui.h \
        aweather-location.c aweather-location.h
 aweather_CPPFLAGS = \
-       -DBROWSER="\"$(browser)\"" \
        -DHTMLDIR="\"$(dots)$(htmldir)\"" \
        -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
        -DPLUGINSDIR="\"$(dots)$(pkglibdir)\""
-aweather_LDADD    = $(GIS_LIBS)
+aweather_LDADD    = $(GRITS_LIBS)
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
 if WIN32
-AM_LDFLAGS       += -mwindows 
-aweather_SOURCES += resource.rc
-dots              = ..
-browser           = "open"
-else
-browser           = "xdg-open"
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
 .rc.o: ../data/aweather.ico
@@ -33,7 +37,9 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       .libs/aweather -o -d 7
+       .libs/aweather -o -d 7 -s KLSX -t '2010-12-31 17:56Z'
+#.libs/aweather -o -d 7 -s KDGX -t '2010-12-31 23:10Z'
+#.libs/aweather -o -d 7 -s KDGX -t '1999-05-03 23:51Z'
 
 gdb: all
        gdb .libs/aweather