]> Pileus Git - aweather/blobdiff - src/Makefile.am
site changing works
[aweather] / src / Makefile.am
index c6b60557c5fcadae6a2f8e139d0dfd4c05c8e858..0617f6aa2507dbb4e390dedfa7f7c656c64d1bb4 100644 (file)
@@ -1,7 +1,23 @@
-AM_CPPFLAGS  = $(GTK_CFLAGS)
-AM_CFLAGS    = -Wall -Werror --std=gnu99
-
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = aweather.c opengl.c cube.c radar.c 
-aweather_LDADD    = $(GTK_LIBS) -lrsl
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+
+test: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       ./aweather
+
+debug: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       gdb ./aweather