]> Pileus Git - aweather/blobdiff - src/Makefile.am
site changing works
[aweather] / src / Makefile.am
index 89408488b632009e423162656474b8fa1dec62b6..0617f6aa2507dbb4e390dedfa7f7c656c64d1bb4 100644 (file)
@@ -3,10 +3,11 @@ AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
 AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = \
-       aweather.c       aweather.h       \
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
        location.c       location.h       \
-       opengl.c         opengl.h         \
        plugin-radar.c   plugin-radar.h   \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
@@ -16,3 +17,7 @@ aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
 test: all
        LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
        ./aweather
+
+debug: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       gdb ./aweather