]> Pileus Git - aweather/blobdiff - src/Makefile.am
Add better debugging support on Windows
[aweather] / src / Makefile.am
index 7bba88f8b6bc0714e886754d2ece864f2c9e2e8a..6a56bc4830308cc9a01698fe9a7f3f2fe68594be 100644 (file)
@@ -17,9 +17,17 @@ wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = $(GLIB_LIBS) -lbz2
 
 if WIN32
-AM_LDFLAGS       += -mwindows 
-aweather_SOURCES += resource.rc
-dots              = ..
+dots = ..
+
+wsr88ddec_LDFLAGS     = -mwindows
+
+aweather_SOURCES     += resource.rc
+aweather_LDFLAGS      = -mwindows
+
+bin_PROGRAMS         += aweather-dbg
+aweather_dbg_SOURCES  = $(aweather_SOURCES)
+aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
+aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
 .rc.o: ../data/aweather.ico