]> Pileus Git - aweather/blobdiff - docs/api/Makefile.am
Converting a lot of stuff to GObject and adding gtk-doc support
[aweather] / docs / api / Makefile.am
diff --git a/docs/api/Makefile.am b/docs/api/Makefile.am
new file mode 100644 (file)
index 0000000..755262f
--- /dev/null
@@ -0,0 +1,17 @@
+AM_CPPFLAGS=$(GTK_CFLAGS)
+GTKDOC_LIBS=$(GTK_LIBS) $(RSL_LIBS) $(CURL_LIBS) \
+       ../../src/aweather-gui.o \
+       ../../src/aweather-view.o \
+       ../../src/location.o \
+       ../../src/opengl.o \
+       ../../src/plugin-example.o \
+       ../../src/plugin-radar.o \
+       ../../src/plugin-ridge.o
+DOC_MODULE=aweather
+DOC_SOURCE_DIR=../../src/
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+include $(top_srcdir)/gtk-doc.make
+maintainer-clean-local:
+       rm -f Makefile.in aweather-docs.sgml aweather-overrides.txt aweather.types
+       rm -rf html/ tmpl/