]> Pileus Git - aweather/blobdiff - docs/Makefile.am
Add user guide to dist
[aweather] / docs / Makefile.am
index e998555129a37b68842c32c535133bfc8129be56..5fddd245c2bbbf56b6fff2f0caadf4539db3ad65 100644 (file)
@@ -1,4 +1,17 @@
-SUBDIRS = api
+man1_MANS = aweather.1 wsr88ddec.1
+html_DATA = aweather.html userguide.html
+
+EXTRA_DIST = $(man1_MANS) $(html_DATA) \
+            aweather.ad userguide.ad wsr88ddec.ad
+
+%.html: %.ad
+       asciidoc $<
+
+%.1: %.ad
+       a2x -f manpage $<
+
+test: $(man1_MANS)
+       nroff -man $(man1_MANS)
 
 maintainer-clean-local:
        rm -f Makefile.in