]> Pileus Git - aweather/blobdiff - data/Makefile.am
Win32 fixes and improvements
[aweather] / data / Makefile.am
index b0e77d7c7e6f2182f9a9d409f4ab403d79d9a2f0..29dadf21616785a734a12ef96f27901b9842dfd3 100644 (file)
@@ -1,10 +1,23 @@
 gtkbuilderdir = $(datadir)/aweather/
-dist_gtkbuilder_DATA = main.xml about.xml
+dist_gtkbuilder_DATA = main.ui
 
-.glade.xml:
-       gtk-builder-convert $< $@
+configdir = $(datadir)/aweather/
+dist_config_DATA = defaults.ini
+
+if WIN32
+noinst_DATA = aweather.ico
+else
+desktopdir = $(datadir)/applications
+dist_desktop_DATA = aweather.desktop
+
+pixmapdir = $(datadir)/pixmaps
+dist_pixmap_DATA = aweather.png
+endif
+
+.svg.png:
+       rsvg -w 48 -h 48 $< $@
+.png.ico:
+       icotool -c $< -o $@
 
-clean-local:
-       rm -f *.xml
 maintainer-clean-local:
        rm -f Makefile.in