]> Pileus Git - aweather/blobdiff - data/Makefile.am
Win32 fixes and improvements
[aweather] / data / Makefile.am
index 4df280f8e865450f8e198febd14061d847e549a9..29dadf21616785a734a12ef96f27901b9842dfd3 100644 (file)
@@ -4,14 +4,20 @@ dist_gtkbuilder_DATA = main.ui
 configdir = $(datadir)/aweather/
 dist_config_DATA = defaults.ini
 
+if WIN32
+noinst_DATA = aweather.ico
+else
 desktopdir = $(datadir)/applications
 dist_desktop_DATA = aweather.desktop
 
 pixmapdir = $(datadir)/pixmaps
 dist_pixmap_DATA = aweather.png
+endif
 
 .svg.png:
-       rsvg $< $@
+       rsvg -w 48 -h 48 $< $@
+.png.ico:
+       icotool -c $< -o $@
 
 maintainer-clean-local:
        rm -f Makefile.in