]> Pileus Git - ~andy/sunrise/blobdiff - x11-plugins/pidgin-lastfm/pidgin-lastfm-0.4a.ebuild
x11-plugins/pidgin-lastfm: New ebuild for pidgin-lastfm, bug #218862
[~andy/sunrise] / x11-plugins / pidgin-lastfm / pidgin-lastfm-0.4a.ebuild
diff --git a/x11-plugins/pidgin-lastfm/pidgin-lastfm-0.4a.ebuild b/x11-plugins/pidgin-lastfm/pidgin-lastfm-0.4a.ebuild
new file mode 100644 (file)
index 0000000..ddd8320
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Last.fm Plugin for the Pidgin Instant Messenger"
+HOMEPAGE="http://pidgin-lastfm.naturalnet.de"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_all.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[perl]"
+
+src_install() {
+       insinto /usr/$(get_libdir)/pidgin
+       doins "${S}"/src/lastfm.pl
+       dodoc "${S}"/docs/* || die "Could not copy doc files."
+}
+
+pkg_postinst() {
+       if has_version "=net-im/pidgin-2.5*" && ! has_version "=dev-lang/perl-5.10*"; then
+               elog "For Perl support in Pidgin 2.5.x, you will need"
+               echo
+               elog "\t>=dev-lang/perl-5.10"
+               echo
+               elog "Unfortunately, Perl 5.10 is not in portage yet. You can get it from the layman overlay perl-experimental."
+               elog "See http://www.gentoo.org/proj/en/overlays/userguide.xml for further information!"
+       fi
+
+       if has_version "=net-im/pidgin-2.4*" && ! has_version "=dev-lang/perl-5.8*"; then
+               elog "For Perl support in Pidgin 2.4.x, you will need"
+               echo
+               elog "\t<=dev-lang/perl-5.8"
+       fi
+}