]> Pileus Git - ~andy/sunrise/blobdiff - x11-misc/kdelnk2wmaker/kdelnk2wmaker-0.06.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / x11-misc / kdelnk2wmaker / kdelnk2wmaker-0.06.ebuild
index 0cff90b0ac6ecd17aa6ee17d7da6860b1b3b9b4a..f497e441e4b6fa443749608fd48a472b27f420e8 100644 (file)
@@ -1,20 +1,29 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=2
+
+inherit eutils toolchain-funcs
+
 DESCRIPTION="Converts .desktop and .kdelnk files to Windowmaker menu format"
-HOMEPAGE="http://members.elysium.pl/ytm/html/kdelnk.html"
-SRC_URI="http://members.elysium.pl/ytm/src/${P}.tar.gz"
+HOMEPAGE="http://ytm.bossstation.dnsalias.org/html/kdelnk.html"
+SRC_URI="http://ytm.bossstation.dnsalias.org/src/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~x86"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-Makefile-fixes.patch
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" || die
+}
 
 src_install() {
-       dodoc AUTHORS BUGS INSTALL README TODO
-       dobin ${PN}
+       dobin ${PN} || die
+       dodoc AUTHORS BUGS README TODO || die
 }