]> Pileus Git - ~andy/sunrise/blobdiff - x11-libs/libqglviewer/libqglviewer-2.3.1.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / x11-libs / libqglviewer / libqglviewer-2.3.1.ebuild
index d005320571921ada00132ac7fdd54e73e4efdbd4..44c009926126a31a6815a5c7aac0f16129f9293b 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="1"
+EAPI="2"
 
-inherit qt4
+inherit qt4-r2
 
 MY_P="libQGLViewer-${PV}"
 
@@ -18,11 +18,15 @@ KEYWORDS="~amd64 ~x86"
 IUSE="doc"
 
 DEPEND="virtual/opengl
-       || ( x11-libs/qt:4 x11-libs/qt-gui )"
+       x11-libs/qt-gui:4"
 RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}/QGLViewer
 
+src_configure() {
+       true
+}
+
 src_compile() {
        eqmake4 QGLViewer.pro -o Makefile PREFIX=/usr
        emake || die "emake QGLViewer failed"