]> Pileus Git - ~andy/sunrise/blobdiff - sys-fs/ntfs3g-ar/ntfs3g-ar-2012.1.15.8.ebuild
sys-fs/ntfs3g-ar: replace rm -rf on sbin with rmdir, add missing 'die' statement...
[~andy/sunrise] / sys-fs / ntfs3g-ar / ntfs3g-ar-2012.1.15.8.ebuild
index 7caec9ae7c59ed086ae033a6edce31f519101559..8f8112dc0423b17437fe1a69c854f692507b7f5a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -75,7 +75,7 @@ src_install() {
        # http://bugs.gentoo.org/398069
        dodir /usr/sbin
        mv "${D}"/sbin/* "${ED}"/usr/sbin || die
-       rm -rf "${D}"/sbin
+       rmdir "${D}"/sbin || die 'rmdir failed'
 
        dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
 }