]> Pileus Git - ~andy/sunrise/blobdiff - sys-fs/aufs/aufs-20080422.ebuild
games-arcade/retrobattle imported into main tree
[~andy/sunrise] / sys-fs / aufs / aufs-20080422.ebuild
index ef7bd4a92490b6eb53ebac16f56a7ca165ec0f5b..792e168917945df9a660d48f028d776e28150864 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -6,7 +6,8 @@ inherit eutils linux-mod
 
 DESCRIPTION="An entirely re-designed and re-implemented Unionfs."
 HOMEPAGE="http://aufs.sourceforge.net/"
-SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2"
+SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2
+       http://dev.gentoo.org/~tommy/distfiles/${P}.tar.bz2"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -32,7 +33,7 @@ pkg_setup() {
                fi
 
                # make sure the user is allowing this to happen
-               if [[ APPLY_SEC_PERM_PATCH="y" ]] ; then
+               if [[ APPLY_SEC_PERM_PATCH = "y" ]] ; then
                        eerror "${PN} requires that all kernels with CONFIG_SECURITY enabled >= 2.6.24"
                        eerror "be patched.  Please enable visit ${HOMEPAGE} and read"
                        eerror "about the sec_perm patch to enable ${PN} support."
@@ -47,7 +48,7 @@ src_unpack(){
        unpack ${A}
        cd "${S}"
 
-       # Enable hinotify in priv_def.mk 
+       # Enable hinotify in priv_def.mk
        if use hinotify && kernel_is ge 2 6 18 ; then
                echo "CONFIG_AUFS_HINOTIFY = y" >> priv_def.mk || die "setting hinotify in priv_def.mk failed!"
        fi
@@ -97,8 +98,8 @@ src_install() {
        cd util
        exeinto /sbin
        exeopts -m0500
-       doexe mount.aufs umount.aufs auplink aulchown
-       doman aufs.5
+       doexe mount.aufs umount.aufs auplink aulchown || die
+       doman aufs.5 || die
        linux-mod_src_install
 }