]> Pileus Git - ~andy/sunrise/blobdiff - sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
sunrise/app-portage/elog-list/elog-list-0.0.6.ebuild: change headers to make repoman...
[~andy/sunrise] / sys-auth / pam_pgsql / pam_pgsql-1.0.0.ebuild
index dd7c191b5dff9e7c9e1628f287257112f1c954bd..24d1740357e2641ea8f2719a4a3e0510c649ebac 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit pam
+WANT_AUTOCONF="2.1"
+inherit pam autotools
 
 DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
 HOMEPAGE="http://pgfoundry.org/frs/?group_id=1000039"
 SRC_URI="mirror://postgresql/projects/pgFoundry/sysauth/${PN/_/-}-${PV}.tgz"
-RESTRICT="mirror"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -17,16 +17,10 @@ KEYWORDS="~amd64 ~x86"
 DEPEND=">=sys-libs/pam-0.78-r3
        >=app-crypt/mhash-0.9.1
        >=dev-db/postgresql-7.3.6"
-
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${PN/_/-}"
 
-src_compile() {
-       econf || die "econf failed"
-       emake CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
 src_install() {
        insinto /etc
        newins "${FILESDIR}/pam_pgsql.conf" pam_pgsql.conf
@@ -35,6 +29,6 @@ src_install() {
 }
 
 pkg_postinst() {
-       einfo "From version 0.6 you can also use new style configuration (overrides"
-       einfo "legacy values). See /usr/share/doc/${PF}/README for more info."
+       elog "From version 0.6 you can also use new style configuration (overrides"
+       elog "legacy values). See /usr/share/doc/${PF}/README for more info."
 }