]> Pileus Git - ~andy/sunrise/blobdiff - sys-apps/zidrav4unix/zidrav4unix-1.2.0.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / sys-apps / zidrav4unix / zidrav4unix-1.2.0.ebuild
index 81e4b6645688c14b57dcaba045168447240b5fb4..705ff9bbc5810be8efcb6247e7f2f00637308cea 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit toolchain-funcs
+EAPI=4
+
+inherit eutils toolchain-funcs
 
 DESCRIPTION="File corruption detection and repair program"
 HOMEPAGE="http://sourceforge.net/projects/zidrav/"
@@ -13,17 +15,17 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE=""
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+src_prepare() {
        sed -i \
                -e "s:g++:$(tc-getCXX):" \
                -e "s:-O2:${CXXFLAGS}:" \
                Makefile || die "sed Makefile failed"
+
+       epatch "${FILESDIR}"/${PV}-gcc46.patch
 }
 
 src_install() {
-       dodoc README TODO Changelog zidrav.txt
-       doman zidrav.1
        dobin zidrav
+       doman zidrav.1
+       dodoc README TODO Changelog zidrav.txt
 }