]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Update live ebuild to reflect the aweather/libgis split
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
index 6c3327e70e7df5d0b91b0209146450fdf1a7eeba..ed6152378a3535ced1fb70f1931279c2f7cdc665 100644 (file)
@@ -3,9 +3,9 @@
 # $Header: $
 
 EGIT_REPO_URI="git://lug.rose-hulman.edu/proj/aweather"
-EGIT_BOOTSTRAP="gtkdocize && eautoreconf"
+EGIT_BOOTSTRAP="eautoreconf"
 
-inherit autotools gnome2 git
+inherit autotools git
 
 DESCRIPTION="A weather monitoring program"
 HOMEPAGE="http://lug.rose-hulman.edu/wiki/AWeather"
@@ -14,19 +14,14 @@ SRC_URI=""
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE="doc"
+IUSE=""
 
-RDEPEND=">=net-libs/libsoup-2.26
+RDEPEND="~sci-libs/libgis-9999
        >=x11-libs/gtk+-2.16
-       x11-libs/gtkglext
        sci-libs/rsl"
+DEPEND="${RDEPEND}"
 
-# gtk-doc-am needed to eautoreconf
-DEPEND="${RDEPEND}
-       dev-util/gtk-doc-am
-       doc? ( dev-util/gtk-doc )"
-
-DOCS="ChangeLog README TODO"
-
-# Fix for gtk-doc bug
-MAKEOPTS="${MAKEOPTS} -j1"
+src_install() {
+       emake DESTDIR="${D}" install || die "install failed"
+       dodoc ChangeLog README TODO || die
+}