]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-0.7.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / sci-geosciences / aweather / aweather-0.7.ebuild
index 3933486772b02518620633116a439fa393bcb516..fa387a24e9b9862f17e0eb8c229133ad51773b40 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -12,11 +12,17 @@ SRC_URI="http://lug.rose-hulman.edu/proj/${PN}/files/${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~x86"
-IUSE=""
+IUSE="gps"
 
 RDEPEND="=sci-libs/grits-${PV}
        x11-libs/gtk+:2
-       sci-libs/rsl"
+       sci-libs/rsl
+       gps? ( >=sci-geosciences/gpsd-3 )"
 DEPEND="${RDEPEND}"
 
 DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+       G2CONF="${G2CONF}
+               $(use_enable gps)"
+}