]> Pileus Git - ~andy/sunrise/blobdiff - net-nntp/sabnzbd/sabnzbd-0.7.2.ebuild
net-nntp/sabnzbd: Version bump and permission improvements for sabnzbd. Thanks to...
[~andy/sunrise] / net-nntp / sabnzbd / sabnzbd-0.7.2.ebuild
similarity index 86%
rename from net-nntp/sabnzbd/sabnzbd-0.7.1.ebuild
rename to net-nntp/sabnzbd/sabnzbd-0.7.2.ebuild
index 60556282d490b13c6bf94d098809deb8b5b4219b..d27afa66fb8761aaaf6a657457f208f87a8728b2 100644 (file)
@@ -48,28 +48,25 @@ src_install() {
        dodoc {ABOUT,CHANGELOG,ISSUES,README}.txt Sample-PostProc.sh
 
        newconfd "${FILESDIR}/${PN}.conf" ${PN}
-
        newinitd "${FILESDIR}/${PN}.init" ${PN}
 
-       # Default configuration file
+       # Default configuration file and directory
+       diropts -m0770 -o root -g ${PN}
+       dodir "${DHOMEDIR}" "${DHOMEDIR}/config"
+
        insinto "${DHOMEDIR}/config"
+       insopts -m0660 -o root -g ${PN}
        doins "${FILESDIR}/${PN}.ini"
 
-       # Assign ownership of SABnzbd default directory
-       fowners -R root:${PN} "${DHOMEDIR}"
-       fperms -R 770 "${DHOMEDIR}"
-
-       # Rotation of logfile
+       # Rotation of log files
        insinto /etc/logrotate.d
+       insopts -m0644 -o root -g root
        newins "${FILESDIR}/${PN}.logrotate" ${PN}
 
        # Add themes & code into /usr/share
        insinto /usr/share/${PN}
+       insopts -m0640 -o root -g ${PN}
        doins -r cherrypy email gntp interfaces locale po sabnzbd SABnzbd.py tools util
-
-       # Adjust permissions in python source directory for root:sabnzbd
-       fowners -R root:${PN} /usr/share/${PN}
-       fperms -R 770 /usr/share/${PN}
 }
 
 pkg_postinst() {
@@ -89,4 +86,4 @@ pkg_postinst() {
 
 pkg_postrm() {
        python_mod_cleanup /usr/share/${PN}
-}
+}
\ No newline at end of file