]> Pileus Git - ~andy/sunrise/blobdiff - net-nntp/nzbperl/nzbperl-0.6.8.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / net-nntp / nzbperl / nzbperl-0.6.8.ebuild
index 3a2a1e9d02d06b413592d534260abc4fafdfa435..cbb9b95291ff5c61a0a18e86ba669251635090ad 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -6,7 +6,7 @@ inherit eutils
 
 DESCRIPTION="nzb based nntp/usenet downloader in perl"
 HOMEPAGE="http://noisybox.net/computers/nzbperl/"
-SRC_URI="http://noisybox.net/computers/nzbperl/${P}.pl"
+SRC_URI="http://noisybox.net/computers/${PN}/${P}.pl"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -18,23 +18,19 @@ DEPEND="dev-lang/perl
        virtual/perl-Time-HiRes
        virtual/perl-Getopt-Long
        dev-perl/TermReadKey
-       dev-perl/Term-ANSIColor
+       virtual/perl-Term-ANSIColor
        dev-perl/XML-DOM
        ssl? ( dev-perl/IO-Socket-SSL )
-       ipv6? ( dev-perl/IO-Socket-INET6 )
-"
-
-src_unpack() {
-       :
-}
+       ipv6? ( dev-perl/IO-Socket-INET6 )"
+RDEPEND="${DEPEND}"
 
 src_install() {
-       newbin "${DISTDIR}/${P}.pl" ${PN}
-       dodoc "${FILESDIR}/${PN}rc.sample"
+       newbin "${DISTDIR}/${P}.pl" ${PN} || die "newbin failed"
+       dodoc "${FILESDIR}/${PN}rc.sample" || die "dodoc failed"
 }
 
 pkg_postinst() {
-       if ! built_with_use dev-lang/perl ithreads; then
+       if has_version dev-lang/perl[-ithreads]; then
                ewarn "WARNING: dev-lang/perl was built with ithreads disabled, please start nzbperl"
                ewarn "with --dthreadct 0 to use single-threaded nzbperl OR remerge dev-lang/perl"
                ewarn "with ithreads in your USE flags."
@@ -43,6 +39,6 @@ pkg_postinst() {
                ewarn "so it is recommended that you build perl with ithreads enabled."
        fi
 
-       elog "A sample config file has been copied into /usr/share/doc/${PF}"
-       elog "You may want to take it as a sample for your ~/.nzbperlrc"
+       einfo "A sample config file has been copied into /usr/share/doc/${PF}"
+       einfo "You may want to take it as a sample for your ~/.nzbperlrc"
 }