]> Pileus Git - ~andy/sunrise/blobdiff - net-mail/qmqtool/qmqtool-1.14.ebuild
net-mail/qmqtool: Version bump. Cleanup.
[~andy/sunrise] / net-mail / qmqtool / qmqtool-1.14.ebuild
diff --git a/net-mail/qmqtool/qmqtool-1.14.ebuild b/net-mail/qmqtool/qmqtool-1.14.ebuild
new file mode 100644 (file)
index 0000000..e4438c2
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="A qmail queue manipulation program"
+HOMEPAGE="http://jeremy.kister.net/code/qmqtool/"
+SRC_URI="http://jeremy.kister.net/code/qmqtool/files/${P}.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/qmail
+       dev-lang/perl"
+
+src_prepare() {
+       # make the configure script less capricious and ${ROOT}-friendly
+       # i.e. replace real directory/file checks with non-empty var checks
+       # and disallow calling perl
+       sed -i \
+               -e 's:\[ -[dx]:[ -n:g' \
+               -e 's:\[ ! -[dx]:[ ! -n:g' \
+               -e '/^$perl/d' \
+               configure || die
+}
+
+src_configure() {
+       # econf-incompatible
+       ./configure \
+               --prefix="${D}"/usr \
+               --scriptdir="${D}"/usr/bin \
+               --perl=/usr/bin/perl \
+               --qmaildir=/var/qmail \
+               || die
+}
+
+src_install() {
+       emake install || die
+       dodoc README FAQ ChangeLog || die "dodoc failed"
+
+       docinto contrib/argus
+       dodoc contrib/argus/* || die "dodoc failed"
+
+       docinto contrib/cricket
+       dodoc contrib/cricket/* || die "dodoc failed"
+}