]> Pileus Git - ~andy/sunrise/blobdiff - net-mail/amavis-logwatch/amavis-logwatch-1.50.03.ebuild
net-mail/amavis-logwatch: Patch the default config location, and remove an unnecessar...
[~andy/sunrise] / net-mail / amavis-logwatch / amavis-logwatch-1.50.03.ebuild
index 9a6fec2fa34057da1a10e627b2ddb02381f5f188..9a9c27b34a58f28f49d5a2bca8b8b9acd3234b97 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI=4
 
+inherit eutils
+
 DESCRIPTION="A log analyzer for amavisd-new"
 HOMEPAGE="http://logreporters.sourceforge.net/"
 SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
@@ -16,6 +18,10 @@ IUSE="logwatch"
 DEPEND="dev-lang/perl"
 RDEPEND="${DEPEND}"
 
+src_prepare() {
+       epatch "${FILESDIR}/default_config_location.patch"
+}
+
 src_compile() {
        # The default make target just outputs instructions. We don't want
        # the user to see these, so we avoid emake.
@@ -29,7 +35,6 @@ src_install() {
        # only installed with USE="logwatch".
        dodoc Bugs Changes README
        doman ${PN}.1
-       dohtml ${PN}.1.html
        dobin ${PN}
        insinto /etc
        doins ${PN}.conf