]> Pileus Git - ~andy/sunrise/blobdiff - net-fs/httpfs/httpfs-2.06.08.26.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / net-fs / httpfs / httpfs-2.06.08.26.ebuild
index 34fc246206c666ffa075b434623254963d7ef656..f208bd307cf039ca524bda6fadddfeec45b37716 100644 (file)
@@ -1,14 +1,16 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+inherit toolchain-funcs
+
 DESCRIPTION="Fuse-based httpfs file system"
 HOMEPAGE="http://httpfs.sourceforge.net/"
 SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
 
 SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 
 IUSE=""
 
@@ -21,8 +23,8 @@ src_unpack() {
        unpack ${A}
        # The script doesn't accept custom CFLAGS. Fix it.
        sed -i \
-               -e 's:^gcc -c -O2 -g -Wall \(.*\)$:gcc -c ${CFLAGS} \1:' \
-               -e 's:^gcc -s \(.*\):gcc ${CFLAGS} \1:' \
+               -e "s:^gcc -c -O2 -g -Wall \(.*\)$:$(tc-getCC) -c ${CFLAGS} \1:" \
+               -e "s:^gcc -s \(.*\):$(tc-getCC) ${CFLAGS} \1:" \
                make_httpfs || die "sed make_httpfs failed"
 }
 
@@ -32,5 +34,5 @@ src_compile() {
 
 src_install() {
        dobin httpfs
-       dodoc readme.2
+       newdoc readme.2 readme
 }