]> Pileus Git - ~andy/sunrise/blobdiff - media-video/ucview_plugins/ucview_plugins-1.0.ebuild
dev-libs/libserial: Adding ~amd64 keyword
[~andy/sunrise] / media-video / ucview_plugins / ucview_plugins-1.0.ebuild
index ed54bd44a2e3dc3c76d60e85a9f5920cdccb3ce1..b0f18dfb8659c0e8ebbd8c369d48b34268761bdd 100644 (file)
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 EAPI=2
 
+inherit autotools
+
 DESCRIPTION="Plugins for UCView image capture application"
 HOMEPAGE="http://unicap-imaging.org/"
 SRC_URI="http://unicap-imaging.org/downloads/${P}.tar.gz"
@@ -19,9 +21,8 @@ DEPEND=">=media-video/ucview-0.30
 RDEPEND=${DEPEND}
 
 src_prepare() {
-       # remove unneeded (and not installed) header include
-       sed -e 's|^#include <ucview/ucview\.h>$|//\0|' \
-                       -i ucview_debayer_plugin/src/debayer_plugin.c || die
+       mkdir -p ucview_{debayer,histogram,videoplay}_plugin/m4
+       eautoreconf
 }
 
 src_configure() {