]> Pileus Git - ~andy/sunrise/blobdiff - media-video/ov51x-jpeg/ov51x-jpeg-1.5.9-r1.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / media-video / ov51x-jpeg / ov51x-jpeg-1.5.9-r1.ebuild
index 8475a24b715b538c67cdc7a6eb595f0d5b5eb9d3..8ccdfe143b89882fb4f1d2e13510fa5371a7ac29 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit linux-mod
+inherit base linux-mod
 
 DESCRIPTION="OV51x driver for Linux which supports JPEG decompression inside the kernel"
 HOMEPAGE="http://www.rastageeks.org/ov51x-jpeg/index.php/Main_Page"
@@ -18,7 +18,12 @@ ERROR_USB="${P} requires Host-side USB support (CONFIG_USB)."
 ERROR_VIDEO_V4L1_COMPAT="${P} require support for the Video For Linux API 1 compatibility layer (CONFIG_VIDEO_V4L1_COMPAT)."
 MODULE_NAMES="ov51x-jpeg(media/video:)"
 BUILD_TARGETS="all"
-BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+
+PATCHES=(
+       "${FILESDIR}"/${PV}-kernel-messages.patch
+       "${FILESDIR}"/${PV}-2.6.29_final.patch
+       )
 
 src_install() {
        linux-mod_src_install