]> Pileus Git - ~andy/sunrise/blobdiff - media-sound/fische/fische-2.0_beta2.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / media-sound / fische / fische-2.0_beta2.ebuild
index 3986ca7b412d2ea41d362e966d671a0493a62a43..2a33c0a4a7917f90ceaf0b6a7ca4c664551572a1 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit versionator
+inherit versionator flag-o-matic
 
 MY_P="${PN}-$(replace_version_separator 2 '-')"
 
@@ -13,10 +13,21 @@ SRC_URI="http://www.aufroof.org/marcel/04_projekte/${MY_P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="mmx sse"
+
+DEPEND="media-libs/libsdl
+       media-libs/alsa-lib"
+RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}
 
+src_compile() {
+       use sse && append-flags -DSSE
+       use mmx && append-flags -DMMX
+       econf
+       emake || die "emake failed"
+}
+
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
 }