]> Pileus Git - ~andy/sunrise/blobdiff - media-sound/basicdsp/basicdsp-1.01.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / media-sound / basicdsp / basicdsp-1.01.ebuild
index ef1bc1a41a661129f08562a3f563d84622e5c568..59aa45bfcce466168b565aa8727c9b7b54b43492 100644 (file)
@@ -1,37 +1,36 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit eutils
+EAPI="3"
+
+WX_GTK_VER="2.8"
+
+inherit eutils toolchain-funcs wxwidgets
 
 DESCRIPTION="A program for experimenting with simple audio DSP algorithms"
 HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/"
 SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz
-       doc? ( http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/BasicDSP_SPRAT.pdf
-       )"
+       doc? ( http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/BasicDSP_SPRAT.pdf )"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~x86"
 IUSE="doc"
 
-DEPEND=">=x11-libs/wxGTK-2.6.3"
-
-src_unpack() {
-       unpack $A
-       cd "${S}"
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
 
+src_prepare() {
        epatch "${FILESDIR}"/makefile.patch
+       tc-export CXX
 }
 
 src_install() {
        dobin basicdsp || die "dobin failed"
        doman basicdsp.1 || die "doman failed"
-       insinto /usr/share/pixmap
-       doins basicdsp_splash.xpm || die "doins failed"
        dodoc README.txt || die "dodoc failed"
        if use doc ; then
                dodoc "${DISTDIR}"/BasicDSP_SPRAT.pdf || die "dodoc failed"
        fi
 }
-